$re = '/^\+?\s?7\s?\(?-?(?# code)[0-9]{3}(?# next 3 digit)\s?\)?-?\s?[0-9]{3}\s?-?(?# next 2 digits)[0-9]{2}\s?-?(?# the last 2 digits)[0-9]{2}/m';
$str = '79001234567
7 900 1234567
7 900 123 45 67
7-900-123-45-67
7 900 123-45-67
7900 123-45-67
7(900)1234567
7 (900) 123 45 67
7 (900) 123-45-67
+79001234567
+7 900 123 45 67
+7 (900) 123-45-67';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);