const regex = /^\+?\s?7\s?\(?-?(?# code)[0-9]{3}(?# next 3 digit)\s?\)?-?\s?[0-9]{3}\s?-?(?# next 2 digits)[0-9]{2}\s?-?(?# the last 2 digits)[0-9]{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?\\s?7\\s?\\(?-?(?# code)[0-9]{3}(?# next 3 digit)\\s?\\)?-?\\s?[0-9]{3}\\s?-?(?# next 2 digits)[0-9]{2}\\s?-?(?# the last 2 digits)[0-9]{2}', 'gm')
const str = `79001234567
7 900 1234567
7 900 123 45 67
7-900-123-45-67
7 900 123-45-67
7900 123-45-67
7(900)1234567
7 (900) 123 45 67
7 (900) 123-45-67
+79001234567
+7 900 123 45 67
+7 (900) 123-45-67`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}