import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?\\s?7\\s?\\(?-?(?# code)[0-9]{3}(?# next 3 digit)\\s?\\)?-?\\s?[0-9]{3}\\s?-?(?# next 2 digits)[0-9]{2}\\s?-?(?# the last 2 digits)[0-9]{2}";
final String string = "79001234567\n"
+ "7 900 1234567\n"
+ "7 900 123 45 67\n"
+ "7-900-123-45-67\n"
+ "7 900 123-45-67\n"
+ "7900 123-45-67\n"
+ "7(900)1234567\n"
+ "7 (900) 123 45 67\n"
+ "7 (900) 123-45-67\n"
+ "+79001234567\n"
+ "+7 900 123 45 67\n"
+ "+7 (900) 123-45-67";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}