$re = '/(\s|\))like(\s|\()/';
$str = 'where ( i like \'b\' ) and concat(a,b) like (\'%\'+@p2+\'%\')
where ( i like \'b\' ) and concat(a,b) like (\'%\'+@p2+\'%\') and a like b
where ( i like \'b\' ) and a like b and concat(a,b) like (\'%\'+@p2+\'%\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);