using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s|\))like(\s|\()";
string input = @"where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b
where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}