import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s|\\))like(\\s|\\()";
final String string = "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')\n"
+ "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b\n"
+ "where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}