package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s|\))like(\s|\()`)
var str = `where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%') and a like b
where ( i like 'b' ) and a like b and concat(a,b) like ('%'+@p2+'%')
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}