$re = '/(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)/mi';
$str = '1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= "52"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);