using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)";
string input = @"1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= ""52""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}