import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<sol>.*?)\\s*(?<isaret>\\<\\>|\\>=|\\>|\\<=|\\<|\\=\\=|\\!\\=)\\s*(?<sag>.*?)\\s*(?<ayrac>&&|\\|\\|)*(\\s|$)";
final String string = "1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= \"52\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}