const regex = /(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<sol>.*?)\\s*(?<isaret>\\<\\>|\\>=|\\>|\\<=|\\<|\\=\\=|\\!\\=)\\s*(?<sag>.*?)\\s*(?<ayrac>&&|\\|\\|)*(\\s|$)', 'gmi')
const str = `1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= "52"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}