re = /^raw_data\.(?!((event_record_string|event_record_binary|event_record_binary\.event_record_binary)\.prod\.(18477|18478|5416|5454|5455)|storage\.aw|codo)\.)(?!.*(failure_permanent|failure_\d+_\w+)$).*/
str = 'raw_data.foo.bar'
# Print the match result
str.match(re) do |match|
puts match.to_s
end