using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^raw_data\.(?!((event_record_string|event_record_binary|event_record_binary\.event_record_binary)\.prod\.(18477|18478|5416|5454|5455)|storage\.aw|codo)\.)(?!.*(failure_permanent|failure_\d+_\w+)$).*";
string input = @"raw_data.foo.bar";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}