import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^raw_data\\.(?!((event_record_string|event_record_binary|event_record_binary\\.event_record_binary)\\.prod\\.(18477|18478|5416|5454|5455)|storage\\.aw|codo)\\.)(?!.*(failure_permanent|failure_\\d+_\\w+)$).*";
final String string = "raw_data.foo.bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}