const regex = /^raw_data\.(?!((event_record_string|event_record_binary|event_record_binary\.event_record_binary)\.prod\.(18477|18478|5416|5454|5455)|storage\.aw|codo)\.)(?!.*(failure_permanent|failure_\d+_\w+)$).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^raw_data\\.(?!((event_record_string|event_record_binary|event_record_binary\\.event_record_binary)\\.prod\\.(18477|18478|5416|5454|5455)|storage\\.aw|codo)\\.)(?!.*(failure_permanent|failure_\\d+_\\w+)$).*', '')
const str = `raw_data.foo.bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}