$re = '/^(.+?)[-. ]{0,3}s?(\d?\d)[ex](\d\d)[-. ]{0,3}(.*?)[-. ]?(?:(?=pulcione|eng|ita|\w+Mux|\w+dl|\d+p|XviD|NovaRip).+)?\.([\w]{2,3})$/im';
$str = 'The.Big.Bang.Theory.S07E01.L.Insufficienza.Da.Hofstadter.ITA.ENG.720p.DLMux.h264-GiuseppeTnT.avi
Bobs.Burgers.3x17.ITA.ENG.ErVaas92[TnT.Village].mkv
American Dad! - 8x03 - Tutore terrore.avi
Supernatural.2x09.Croatoan.ITA.DVDMux.XviD-NovaRip.avi
Futurama 07x03 Verdetto 3012 480p WEBDL x264 mSD EiZO.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);