#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(.+?)[-. ]{0,3}s?(\d?\d)[ex](\d\d)[-. ]{0,3}(.*?)[-. ]?(?:(?=pulcione|eng|ita|\w+Mux|\w+dl|\d+p|XviD|NovaRip).+)?\.([\w]{2,3})$"
Local $sString = "The.Big.Bang.Theory.S07E01.L.Insufficienza.Da.Hofstadter.ITA.ENG.720p.DLMux.h264-GiuseppeTnT.avi" & @CRLF & _
"Bobs.Burgers.3x17.ITA.ENG.ErVaas92[TnT.Village].mkv" & @CRLF & _
"American Dad! - 8x03 - Tutore terrore.avi" & @CRLF & _
"Supernatural.2x09.Croatoan.ITA.DVDMux.XviD-NovaRip.avi" & @CRLF & _
"Futurama 07x03 Verdetto 3012 480p WEBDL x264 mSD EiZO.mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")