import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)[-. ]{0,3}s?(\\d?\\d)[ex](\\d\\d)[-. ]{0,3}(.*?)[-. ]?(?:(?=pulcione|eng|ita|\\w+Mux|\\w+dl|\\d+p|XviD|NovaRip).+)?\\.([\\w]{2,3})$";
final String string = "The.Big.Bang.Theory.S07E01.L.Insufficienza.Da.Hofstadter.ITA.ENG.720p.DLMux.h264-GiuseppeTnT.avi\n"
+ "Bobs.Burgers.3x17.ITA.ENG.ErVaas92[TnT.Village].mkv\n"
+ "American Dad! - 8x03 - Tutore terrore.avi\n"
+ "Supernatural.2x09.Croatoan.ITA.DVDMux.XviD-NovaRip.avi\n"
+ "Futurama 07x03 Verdetto 3012 480p WEBDL x264 mSD EiZO.mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}