using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)[-. ]{0,3}s?(\d?\d)[ex](\d\d)[-. ]{0,3}(.*?)[-. ]?(?:(?=pulcione|eng|ita|\w+Mux|\w+dl|\d+p|XviD|NovaRip).+)?\.([\w]{2,3})$";
string input = @"The.Big.Bang.Theory.S07E01.L.Insufficienza.Da.Hofstadter.ITA.ENG.720p.DLMux.h264-GiuseppeTnT.avi
Bobs.Burgers.3x17.ITA.ENG.ErVaas92[TnT.Village].mkv
American Dad! - 8x03 - Tutore terrore.avi
Supernatural.2x09.Croatoan.ITA.DVDMux.XviD-NovaRip.avi
Futurama 07x03 Verdetto 3012 480p WEBDL x264 mSD EiZO.mkv";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}