import Foundation
let pattern = #"(?:musicdb|videodb|special):\/\/(?<Type>albums|tvshows|genres|masterprofile|artists)\/(?:titles\/)?(?<Identifier>[\w\d\-.]+)\/?(?<Season>\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
musicdb://albums/2/
videodb://tvshows/titles/1/
videodb://tvshows/titles/1/5/?tvshowid=1
musicdb://genres/2/
special://masterprofile/PartyMode-Video.xsp
musicdb://artists/2/?albumartistonly=false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)