#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:musicdb|videodb|special):\/\/(?<Type>albums|tvshows|genres|masterprofile|artists)\/(?:titles\/)?(?<Identifier>[\w\d\-.]+)\/?(?<Season>\d+)?"
Local $sString = "musicdb://albums/2/" & @CRLF & _
"videodb://tvshows/titles/1/" & @CRLF & _
"videodb://tvshows/titles/1/5/?tvshowid=1" & @CRLF & _
"musicdb://genres/2/" & @CRLF & _
"special://masterprofile/PartyMode-Video.xsp" & @CRLF & _
"musicdb://artists/2/?albumartistonly=false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")