using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:musicdb|videodb|special):\/\/(?<Type>albums|tvshows|genres|masterprofile|artists)\/(?:titles\/)?(?<Identifier>[\w\d\-.]+)\/?(?<Season>\d+)?";
string input = @"musicdb://albums/2/
videodb://tvshows/titles/1/
videodb://tvshows/titles/1/5/?tvshowid=1
musicdb://genres/2/
special://masterprofile/PartyMode-Video.xsp
musicdb://artists/2/?albumartistonly=false";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}