const regex = /(?:musicdb|videodb|special):\/\/(?<Type>albums|tvshows|genres|masterprofile|artists)\/(?:titles\/)?(?<Identifier>[\w\d\-.]+)\/?(?<Season>\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:musicdb|videodb|special):\\\/\\\/(?<Type>albums|tvshows|genres|masterprofile|artists)\\\/(?:titles\\\/)?(?<Identifier>[\\w\\d\\-.]+)\\\/?(?<Season>\\d+)?', 'gm')
const str = `musicdb://albums/2/
videodb://tvshows/titles/1/
videodb://tvshows/titles/1/5/?tvshowid=1
musicdb://genres/2/
special://masterprofile/PartyMode-Video.xsp
musicdb://artists/2/?albumartistonly=false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}