# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/dev\/sd[a-z][a-z]?(?<!\/dev\/sda)"
test_str = ("/dev/sda\n"
"/dev/sdb\n"
"/dev/sdc\n"
"/dev/sdd\n"
"/dev/sde\n"
"/dev/sdaa\n"
"/dev/sdab\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.