const regex = /\/dev\/sd[a-z][a-z]?(?<!\/dev\/sda)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/dev\\\/sd[a-z][a-z]?(?<!\\\/dev\\\/sda)', 'g')
const str = `/dev/sda
/dev/sdb
/dev/sdc
/dev/sdd
/dev/sde
/dev/sdaa
/dev/sdab
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);