# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/dev\\/sd[a-z][a-z]?(?<!\\/dev\\/sda)//g;t' <<< "/dev/sda
/dev/sdb
/dev/sdc
/dev/sdd
/dev/sde
/dev/sdaa
/dev/sdab
"