use strict;
my $str = '/dev/sda
/dev/sdb
/dev/sdc
/dev/sdd
/dev/sde
/dev/sdaa
/dev/sdab
';
my $regex = qr/\/dev\/sd[a-z][a-z]?(?<!\/dev\/sda)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";