re = /<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>/
str = '<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style="somestyle">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result