const regex = new RegExp('<h\\d{1}(?:.*?)>(?<title>.*?)<\\/h\\d{1}>', 'g')
const str = `<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style="somestyle">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);