# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>"
test_str = ("<h1>This is a large heading</h1>\n"
"<p>This is a sample content paragraph.</p>\n"
"<h2 style=\"somestyle\">This header line</h2>\n"
"<p>This is another content paragraph.</p>\n"
"<h2>Another header line</h2>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.