# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h\d{1}(?:.*?)>(?<title>.*?)<\\/h\d{1}>//g;t' <<< "<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style=\"somestyle\">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>"