import Foundation
let pattern = #"^\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/tempban networkException 1 mo pls work this time
/tempban networkException 1s testing again
/tempban -s networkException 1s testing again
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)