const regex = /^\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$', 'gm')
const str = `/tempban networkException 1 mo pls work this time
/tempban networkException 1s testing again
/tempban -s networkException 1s testing again`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}