$re = '/^\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$/m';
$str = '/tempban networkException 1 mo pls work this time
/tempban networkException 1s testing again
/tempban -s networkException 1s testing again';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);