#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$"
Local $sString = "/tempban networkException 1 mo pls work this time" & @CRLF & _
"/tempban networkException 1s testing again" & @CRLF & _
"/tempban -s networkException 1s testing again"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")