re = /^([a-zA-Z]:(?=\\)|\\\\(?:[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+|\?\\(?:[a-zA-Z]:(?=\\)|(?:UNC\\)?[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+)))/
str = 'C:\\a\\path
\\\\server\\share\\some\\path
\\\\?\\C:\\a\\path
\\\\?\\server\\share\\a\\path
\\\\?\\UNC\\server\\share\\a\\path'
# Print the match result
str.match(re) do |match|
puts match.to_s
end