$re = '/^([a-zA-Z]:(?=\\\\)|\\\\\\\\(?:[^\*:<>?\\\\\/|]+\\\\[^\*:<>?\\\\\/|]+|\?\\\\(?:[a-zA-Z]:(?=\\\\)|(?:UNC\\\\)?[^\*:<>?\\\\\/|]+\\\\[^\*:<>?\\\\\/|]+)))/';
$str = 'C:\\a\\path
\\\\server\\share\\some\\path
\\\\?\\C:\\a\\path
\\\\?\\server\\share\\a\\path
\\\\?\\UNC\\server\\share\\a\\path';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);