using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]:(?=\\)|\\\\(?:[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+|\?\\(?:[a-zA-Z]:(?=\\)|(?:UNC\\)?[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+)))";
string input = @"C:\a\path
\\server\share\some\path
\\?\C:\a\path
\\?\server\share\a\path
\\?\UNC\server\share\a\path";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}