const regex = /^([a-zA-Z]:(?=\\)|\\\\(?:[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+|\?\\(?:[a-zA-Z]:(?=\\)|(?:UNC\\)?[^\*:<>?\\\/|]+\\[^\*:<>?\\\/|]+)))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]:(?=\\\\)|\\\\\\\\(?:[^\\*:<>?\\\\\\\/|]+\\\\[^\\*:<>?\\\\\\\/|]+|\\?\\\\(?:[a-zA-Z]:(?=\\\\)|(?:UNC\\\\)?[^\\*:<>?\\\\\\\/|]+\\\\[^\\*:<>?\\\\\\\/|]+)))', '')
const str = `C:\\a\\path
\\\\server\\share\\some\\path
\\\\?\\C:\\a\\path
\\\\?\\server\\share\\a\\path
\\\\?\\UNC\\server\\share\\a\\path`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}