import Foundation
let pattern = ##"""
# Keys are pretty much "any text before the '=' symbol"
(?P<key>[^=]+)
# Match the '=' symbol
=
(?P<value>
# Lazy match
.*?
# Look-ahead (don't move the "regex cursor", just "peek forward")
(?=
# Match a '_' that has no other '_' between it and the '=' character, or...
_[^_=\n]+=
|
# ... or the end of the line
$
)
)
# Actually "consume" the '_' character if it exists (or just match the end-of-line)
(?:_|$)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
str=string_number=12345_device=phone_color=blue
color=aqua_marine_name=matt_number=123_456_879_lastname=blahblah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 = \2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)