const regex = new RegExp('# Keys are pretty much "any text before the \\'=\\' symbol"
(?P<key>[^=]+)
# Match the \\'=\\' symbol
=
(?P<value>
# Lazy match
.*?
# Look-ahead (don\\'t move the "regex cursor", just "peek forward")
(?=
# Match a \\'_\\' that has no other \\'_\\' between it and the \\'=\\' character, or...
_[^_=\\n]+=
|
# ... or the end of the line
$
)
)
# Actually "consume" the \\'_\\' character if it exists (or just match the end-of-line)
(?:_|$)', 'gm')
const str = `str=string_number=12345_device=phone_color=blue
color=aqua_marine_name=matt_number=123_456_879_lastname=blahblah`;
const subst = `\1 = \2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);