import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Keys are pretty much \"any text before the '=' symbol\"\n"
+ "(?P<key>[^=]+)\n\n"
+ "# Match the '=' symbol\n"
+ "=\n\n"
+ "(?P<value>\n"
+ " # Lazy match\n"
+ " .*?\n\n"
+ " # Look-ahead (don't move the \"regex cursor\", just \"peek forward\")\n"
+ " (?=\n"
+ " # Match a '_' that has no other '_' between it and the '=' character, or...\n"
+ " _[^_=\\n]+=\n"
+ " |\n"
+ " # ... or the end of the line\n"
+ " $\n"
+ " )\n"
+ ")\n\n"
+ "# Actually \"consume\" the '_' character if it exists (or just match the end-of-line)\n"
+ "(?:_|$)";
final String string = "str=string_number=12345_device=phone_color=blue\n"
+ "color=aqua_marine_name=matt_number=123_456_879_lastname=blahblah";
final String subst = "\\1 = \\2\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}