// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\,\-?!*½=+$#£(){} % ]+").unwrap();
let string = "Allahümmerzuknaâ kalben takiyyen mineşşirki
beriyyen la kafiren ve la @£$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !\"#¤%&'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}