# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\,\-?!*½=+$#£(){} % ]+//;t' <<< "Allahümmerzuknaâ kalben takiyyen mineşşirki
beriyyen la kafiren ve la @£$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !\"#¤%&'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà "