re = /[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\,\-?!*½=+$#£(){} % ]+/
str = 'Allahümmerzuknaâ kalben takiyyen mineşşirki
beriyyen la kafiren ve la @£$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !"#¤%&\'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà '
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result