import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\\\,\\-?!*½=+$#£()\\{\\} % ]+";
final String string = "Allahümmerzuknaâ kalben takiyyen mineşşirki \n"
+ "beriyyen la kafiren ve la @£$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !\"#¤%&'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}