re = /(?=\s|\.)(\s|.)(multi|dual|ita-eng)(?=\s|\.)(\s|.)/m
str = 'ds.multi.
dsd dual
ds.ita-eng.
this is multiplayer
dualipa
dual
.dual.
dual.
italian and english
this is aramulti '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end