const regex = /(?=\s|\.)(\s|.)(multi|dual|ita-eng)(?=\s|\.)(\s|.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\s|\\.)(\\s|.)(multi|dual|ita-eng)(?=\\s|\\.)(\\s|.)', 'gm')
const str = `ds.multi.
dsd dual
ds.ita-eng.
this is multiplayer
dualipa
dual
.dual.
dual.
italian and english
this is aramulti `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}