$re = '/(?=\s|\.)(\s|.)(multi|dual|ita-eng)(?=\s|\.)(\s|.)/m';
$str = 'ds.multi.
dsd dual
ds.ita-eng.
this is multiplayer
dualipa
dual
.dual.
dual.
italian and english
this is aramulti ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);