using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\s|\.)(\s|.)(multi|dual|ita-eng)(?=\s|\.)(\s|.)";
string input = @"ds.multi.
dsd dual
ds.ita-eng.
this is multiplayer
dualipa
dual
.dual.
dual.
italian and english
this is aramulti ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}